vendor/Five/1.2b-r20590

view INSTALL.txt @ 0:3673ed425f80

Vendor import of Five 1.2b+ (r20590)
author fguillaume
date Fri, 02 Dec 2005 20:25:42 +0000
parents
children
line source
1 How to install Five
2 ===================
4 Requirements for Five 1.2
5 -------------------------
7 * Zope 2.8.1+ with Python 2.3.x. Zope 2.8.5+ is recommended as it
8 contains a bugfix regarding Zope 3-style skins.
10 Note that Five 1.0 is already part of Zope 2.8. This doesn't matter,
11 though, you can still install Five 1.2 into your Zope 2.8 instances.
12 It will override Zope's older version of Five.
15 Compatability matrix
16 --------------------
18 The following table shows which Five version can and should be used
19 with which Zope 2 and Zope 3 versions.
21 ============ ======================= =========== ========
22 . Zope 2.7 Zope 2.8 Zope 2.9
23 ------------ ----------------------- ----------- --------
24 . Zope X3 3.0 (not incl.) Zope X3 3.0 Zope 3.2
25 ============ ======================= =========== ========
26 Five 1.0 X included
27 Five 1.1[#]_ X X
28 Five 1.2 X
29 Five 1.3 included
30 ============ ======================= =========== ========
32 .. [#] This branch is no longer actively maintained.
35 Running the tests
36 -----------------
38 For information on how to install the automatic Five tests, please see
39 ``tests/README.txt``.